Saturday, 24 March 2018

Steps were taken to add Firebase and One Signal Plugins for Android:



Step 1:
Was getting unidentified error so to get identifiable error, downgrade the one signal version by changing One Signal/Editor/OneSignalEditorScript/ Android Support Version + => 27+

Step 2:
After that started getting Dex Limit Error. To remove you need to start building Android Project using Gradle
Follow step given on this link: here
       

Step 3:

After that when you start building for Gradle you can get an error like Building Error or Gradle Build Failed
Ex.  Build-in class shrinker and multidex are not supported yet
Remove

useProguard **PROGUARD_DEBUG**

from the [android] -> [buildTypes] -> [debug] block.

Remove

useProguard **PROGUARD_RELEASE**

from the [android] -> [buildTypes] -> [release] block.

To remove issue you need to make sure if build.gradle is correct.
Problem that I faced was:
If you are using Pro Gaurd to minify then make sure to add

buildTypes {
  debug {

  }
  release {
  minifyEnabled true
           shrinkResources true
  }
}
If not using minify put false in both place.

try bellow link it gives solution to every problem you will encounter
https://gist.github.com/yatyricky/3045db85191c410da44029b0c7b7aaf6

Step 4:

If started getting error like DaydreamApi Warning then remove minify enables in debug
buildTypes {
  debug {
minifyEnabled true
  }
Use progaurd file and add
-dontwarn com.google.vr.ndk.base.DaydreamApi


Step 5:

If getting error like
Resource '@integer/google_play_services_version' not found in AndroidManifest.xml

Copy
<meta-data android:name="com.google.android.gms.version" android:value="@integer/google_play_services_version" />

from
Assets/GooglePlayGames/Plugins/Android/GooglePlayGamesManifest.plugin/AndroidManifest.xml
To
Plugins/Android/AndroidManifest.xml


No comments:

Post a comment